Animation

  1. 9 months ago

    Joel_Eisenstat

    8 Feb 2017 User since 2016

    Good morning,
    In playing with animation I am attempting to create a "privacy screen" where the backgroundColor
    increases to obscure the object. Any hints on not having the object revert to the initial background.
    Thanks,
    Joel

  2. Joel_Eisenstat

    8 Feb 2017 User since 2016

    BTW the animation screen works on Creo player except for the table object .
    Joel

  3. marco

    8 Feb 2017 Administrator User since 2016
    Edited 9 months ago by marco

    Hi @Joel_Eisenstat,
    just set the Fill Mode property to forwards in order to not having animation properties reverted back to the original values (as shown in the attached screenshot).

    P.S. this works only in runtime mode not in the design board preview mode. You can execute an animation on runtime using the Animation1.play(); code (for example in the Action event of a Button).

  4. marco

    8 Feb 2017 Administrator User since 2016

    @Joel_Eisenstat what do you mean by "the animation screen works on Creo player except for the table object" ?

  5. Joel_Eisenstat

    8 Feb 2017 User since 2016

    When moving the project over to the Creo Player all objects linked to the animation work as in preview except for the table object .

  6. marco

    9 Feb 2017 Administrator User since 2016

    @Joel_Eisenstat which Table properties have you animated? Do you have some sample code to share?

  7. Joel_Eisenstat

    9 Feb 2017 User since 2016

    backroundColor (?) property -

or Sign Up to reply!