VinDo

Member

Last active 11 months ago

  1. 11 months ago
    Sun Jun 16 16:29:07 2019
    VinDo posted in Auth0 - Identity Management.

    Andrea, I notice you have done an Auth0 tech note many thanks.

    Is there a way of removing the access token once a user is logged in? so that the user is essentially logged out and/or force them to login again? Or does the logout endpoint do this?

    I have tried using the Auth0 logout endpoint - which appears to send (text connection responds with ok) - but doesn't appear to remove the token, or log out the user?

    Regards

    VinDo

  2. Mon Jun 10 20:05:54 2019
    VinDo posted in Auth0 - Identity Management.

    Andrea, this is really useful many thanks. I have re-worked into a deployed application - and works great. I shall build in this.
    VinDo

  3. Thu Jun 6 07:17:12 2019
    VinDo started the conversation Auth0 - Identity Management.

    I am trying to build a 'login and password' capability to allow access to authorised users to an app - so that data, stored in the cloud can be downloaded into the app.

    I have considered writing a 'logon' application but would require hashing techniques and an online secure database - I have chosen instead to use Auth0 - an online identity management as a service.

    The attached app - opens the universal login interface from Auth0 in a web view - and I have successfully logged in (according to Auth0) - I haven managed to get the redirect uri to work however. I am stumbling in two parts:

    1) The application doesn't appear to run on the phone in Creoplayer (more than once) - I am not sure if this is related to 'web history, cookies, or locally held tokens? or something else. - the app does run in the simulator on Creo on the Mac (at least once!).

    2) Once authorised I can't work out how to handle the redirect uri that Auth0 issues - and open the meat of the app (loading window)
    I have tried to implement the handling of opening the main page in the app using an incoming URL - (openurl) - but either I have got this wrong or because the redirect is coming from inside the app - the openurl isn't applicable...

    My aim is to have user authentication incorporated into an iPhone app -

    I have attached my app - below!

    Any thoughts gratefully received

  4. last year
    Sat Oct 20 08:31:40 2018
    VinDo posted in Upload Image to Cloudinary.

    Andrea, this is fantastic many thanks for your help

  5. Thu Oct 18 06:10:25 2018
    VinDo started the conversation Upload Image to Cloudinary.

    Does anyone have a working example of uploading an image from the app to Cloudinary?

    I have followed an example posted on these forums that uploads to Imgur. But I haven't been able to replicate success with Cloudinary!

    Attached is my attempt!

  6. Mon Jul 2 10:01:59 2018
    VinDo started the conversation Changing Data in DataGrid programmatically.

    Is there a way of changing the data in the data grid programatically?
    I would like to amend the data in the datagrid in response to a slider, or input from the user in the final application in real time.
    Any thoughts?

  7. Sat Jun 16 16:19:15 2018
    VinDo posted in Build for Distribution.

    Marco
    Many thanks. I have now upgraded to the 1.0.0 - I'm still unlicensed (waiting until I can get the build working).
    The build appears to get to the App Store Connect now and is processed succssfully - but doesn't get to TestFlight -
    The following message comes from Apple -

    Missing beta entitlement - Your app does not include the beta-reports-active entitlement. If you intend to distribute this build via TestFlight for beta testing, please re-build this app with an App Store Distribution provisioning profile. Do not use ad-hoc profiles.

    I am building with:
    Package Distribution: iOS App Store Distribution
    Signing Identity: iPhone Distribution: in my name
    Provisioning Profile: iOS Provisioning Profile (Distribution)

  8. 2 years ago
    Sun May 27 09:16:37 2018
    VinDo started the conversation Build for Distribution.

    I've designed an app. Building it generates the correctly provisioned .ipa file.
    Using the apple application loader app - I get this error form iTunes connect.

    It suggests that there is not a 76x76 icn in png.

    I used the icon generator in the Creo icon dialog... the icon named icon-76@2x.png is actually 152x152 pixels - if I replace it with a 76x76 then I get the message that the bundle doesn't include a 152x152 icon...

    I am planning to use testflight - to test my app - will the build still work for test flight?

  9. Mon May 14 06:42:23 2018
    VinDo posted in Airtable API connectivity.

    This structure works...
    Airtable.host = AirtableURL + "/" + Record;
    Airtable.Request.run();

    where:
    Airtable is a HTTPClient - that has the Airtable base URL (using the query for the air_key)
    AirtableURL is the base URL in a variable
    Record is the unique id of the record (as used by Airtable)
    Airtable.Request is the HTTPRequest call

    (I'm using a variation of the LetsCook tutorial - using a HTTPClient instead of the local SQL - and still struggling to get the HTTPRequest to update the second window...)

  10. Wed May 9 07:28:07 2018
    VinDo started the conversation Airtable API connectivity.

    I am using the HTTPClient and HTTPRequest to connect to Airtable API.
    The connection works - if I use the api_key as a query
    And the request returns all the records in an airtable base
    I am trying to restrict the HTTPRequest to querying for only one record in the base. I can’t work out how to configure the HTTPClient with a ‘variable’ - the API takes the record id as part of the url.
    Any thoughts?

View more